Logo de Hulu

Hulu no funciona directamente en las distribuciones modernas de Linux. Mientras que Netflix sólo funciona si estás usando Google Chrome, el sistema de derechos digitales de Hulu es anticuado y no ofrece compatibilidad. Pero puedes hacer que Hulu funcione en Linux gracias a algunos ajustes que vamos a presentarte más abajo.

Esto no siempre fue tan duro, cuando Netflix comenzó a hacerles la vida difícil a los usuarios de Linux, Hulu incluso ofrecía una aplicación para ellos, aunque la aplicación se encuentra descontinuada en la actualidad. Hulu está basado en Adobe flash y el código del Flash se está cayendo a pedazos en la plataforma de Linux.

Deberás usar Firefox

El problema es que Hulu está basado en los viejos códigos de Adobe Flash, lo que requiere una librería de Linux conocida como HAL. Sin embargo, este software está bastante desactualizado y ya no viene instalado por defecto en las nuevas distribuciones de Linux. Es por esto que necesitarás instalar paquetes de compatibilidad que permitan la funcionalidad de los programas basados en HAL.

También deberás utilizar Mozilla Firefox para ver Hulu pues los viejos programas basados en HAL solo trabajan con las versiones antiguas del plugin de Flash que ofrece Firefox para Linux. El nuevo reproductor Flash basado en PPAPI que viene incluido en Google Chrome no funciona con los viejos códigos de Hulu. Sí, todo esto significa que tendrás que utilizar Google Chrome para ve Netflix y Mozilla Firefox para ve Hulu.

Hulu Flash

Paso uno: Instalar Flash en Firefox

Lo primero que tienes que hacer es instalar el plugin del Reproductor Flash para Firefox, si aun no lo has instalado, una vez que intentes ver Hulu aparecerá un mensaje diciendo que primero necesitas tener instalado el Flash. Generalmente puedes instalar el plugin desde los almacenes de software para distribuciones Linux, por ejemplo, en Ubuntu puedes ingresar al Centro de Software de Ubuntu y buscar el Flash, luego instalarás el “Adobe Flash plug-in”.

Asegúrate de instalar el plugin Flash diseñado para Mozilla, Firefox o NPAPI, ya que la versión PPAPI o para Chromium sólo funcionará en los exploradores basados en Chrome o Chromium.

Flash en Ubuntu

Paso dos: Instalar la librería HAL

Una vez que tengas instalado Firefox con su respectivo plugin de Flash, podrás ingresar al sitio web de Hulu e intentar reproducir algo, sin embargo, recibirás un mensaje de error cuando lo hagas.

El mensaje de error dirá que se ha presentado un problema con un contenido protegido, Hulu te pedirá que te asegures que el paquete HAL está instalado, que limpies el cache del Flash o que reinicies los archivos de licencia. Además, Hulu te redireccionará a una página de Adobe donde se recomienda instalar el paquete HAL, sin embargo, este paquete ya no está disponible para las nuevas versiones de las distribuciones de Linux.

Error en Hulu

En lugar de tener que instalar una versión completa del paquete de HAL, desde el “PPA HAL zombie” como se conoce en los círculos de Ubuntu, te vamos a guiar por una solución más ligera.

Martin Wimpress, líder del proyecto Ubuntu MATE, suministra un paquete de archivos de HAL-Flash que te otorga todo lo necesario para reproducir contenido Flash sin necesidad de instalar el paquete completo de HAL.

Para instalar este software, necesitarás añadir el paquete a tu sistema Ubuntu, Linux Mint o cualquier otra distribución derivada de Ubuntu. Para ello abre el terminal y procede a escribir los siguientes códigos, cada uno por separado y presionando Enter después de cada uno. El primer comando va a añadir el paquete, el segundo código descarga la información necesaria del paquete y el tercero instala la librería de HAL. Los códigos son los siguientes:

sudo add-apt-repository ppa:flexiondotorg/hal-flash

sudo apt-get update

sudo apt-get install libhal1-flash

Si estás utilizando alguna distribución distinta a Linux Mint o las derivadas de Ubuntu, necesitarás buscar un paquete HAL para el Flash que esté disponible para tu distribución de Linux. Podría formar parte de los almacenes de tu distribución de Linux o quizás ser un software de terceros como lo es para Ubuntu.

Una vez instalado, ingresa de nuevo a Hulu desde el Firefox, esta vez al intentar reproducir algún contenido no debería aparecer ningún error de “contenido protegido”. Si al realizar esto el explorador sigue mostrando el error, deberás cerrarlo y volverlo a abrir; si el error persiste entonces tendrás que reiniciar la máquina para que los cambios del paquete sean guardados.

Este ha sido un problema desde hace algunos años, el sitio web de Adobe ha dicho que el HAL debe ser instalado en todas las versiones de Ubuntu del 10 en adelante, lo que serian más o menos todas las distribuciones lanzadas del 2010 hasta la fecha.

Adobe ya no quiere desarrollar Flash en Linux. Y la solución real al problema no vendrá cuando Adobe arregle su Flash DRM, sino cuando Hulu decida actualizar su plataforma a HTML5, tal y como lo ha hecho Netflix en Google Chrome. Hasta que lo hagan, reproducir Hulu en Linux seguirá siendo complicado.



¿Cómo ver Hulu en Ubuntu y otras distribuciones de Linux?
Califica este artículo